Ressources

User manual for YupiF7 : user-manual-yupif7-rev1

User manual for the race version: manuel-utilisation-yupif4-race-rev2

BetaFlight 3.3.0 for YuPiF4 Race  : available in the firmware updater of betaflight

BetaFlight 3.3.0 for YuPiF4 : available in the firmware updater of betaflight

Link to the facebook page : https://www.facebook.com/YupiFC/

Plans de câblage

YupiF4 Race V1.0 et V1.1

cab-race-front-600

YupiF4 Mini V1.0

cablage_yupif4_mini

YupiF7

quickstartyupif7

Q & A

I have strong vibrations
  • Check if the flight controller is correctly screwed
    • if yes, go next
  • Change PID in the configurator with the following values : P[Roll/Pitch/Yaw]=30 – I[Roll/Pitch/Yaw]=45 – D[Roll/Pitch]=25
I can’t connect to the flight controller
  • Check if LEDs are blinking
    • if no, go on DFU mode pushing the Boot button while plugging the usb port. Once the DFU mode detected (« DFU » is writen in the top write corner of the configurator), flash the last firmware
    • if « DFU » doesn’t appear, try to reinstall DFU drivers : http://www.st.com/st-web-ui/
    • if after driver installation « DFU » doens’t appear, please contact the YupiF4 support
    • if yes, go next
  • check if a Com port is detected by the configurator
    • if no, go on DFU mode pushing the Boot button while plugging the usb port. Once the DFU mode detected (« DFU » is writen in the top write corner of the configurator), flash the last firmware
    • if you still have the problem after reflashing the board, try to reinstall USB VCP drivers: http://www.st.com/en/development-tools/stsw-stm32102.html
    • if a Com port is detected (visible in the top write corner of the configurator),please contact the YupiF4 support
How can I update the Firmware of my flight controller
Why motors are accelerating continuously without props
  • That is the flight controller trying to correct for changes in aspect, mainly due to fact your quad shakes slightly when the motors spin, the sensors pick it up and then the flight controller tries to correct, it can’t because you don’t have props on. All perfectly normal.
The OSD is showing random characters on the video

Update the OSD fonts with the configurator, following these steps :

  • Plug the Lipo
  • Plug the flight conroller to a configurator (Betaflight, Cleanflight…)
  • Go to OSD tab
  • Click on « Font Manager » in the bottom write corner
  • Select the desired Font and click « Upload Font »